Discussion in 'Computer Software' started by S C O R P Y, Jul 25, 2006.

  1. S C O R P Y

    S C O R P Y New Member

    Somebody pls tell me how to enable registry editing in windows XP. I tried executing "regedit" in run but I get an error message reading "Registry Editing disabled by Administrator" and my comp suddenly restarts after that. Pls tell me what do I do now???
  2. blaster

    blaster New Member

    Goto RUN

    type gpedit.msc

    locate following path

    User Configuration > System

    Right Click Prevent Access To Registry Editing Tools , goto properties

    Check Disable radio button
  3. bluediamond

    bluediamond Well-Known Member

    sorry to bump this thread up....

    but i am facing the same problem... except that i DONT get even the error message, and thankfully the system is not restarting...

    I tried the gpedit.msc and it says not configured for the registry access.. i tried enabling, disabling, and back to not configured and tried even restarting, but to no use...

    i even checked manually the system32 folder.. there is regedit32.exe and not a .com or any other virus kinda file for regedit.

    what exactly is the problem here.. why am i not even getting error messages or warnings regarding the registry?

    OT: i wanted to edit the registry for cleaning up NOD32. its giving "error communicating NOD32 kernel service" thought of a fresh install after cleaning registry.. is there any other way for this too?
  4. madmaniac

    madmaniac Well-Known Member

    @ S C O R P Y

    Ok no matter how many times you try enabling registry editing it wont work because your comp is infested with a virus which disables registry editing, removes ability to view hidden folders and files and also generally restarts when it detects you are trying to enable these things.

    What you need to do is install a good antivirus and do a boot time scan or a scan in safe mode. Then when you enable registry editing and hidden files etc. your comp wont restart.


    yours is a different problem :S
  5. S@ndeep

    S@ndeep New Member

    @Scorpy: This error occurs if the DisableRegistryTools Policy is enabled.

    Start->Run and type 'REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0 /f'

    After that try to open Registry using 'Regedit' from start->Run.

    Also, it is likely that the system is infected by Virus. Try getting latest anti-virus software and run a complete system scan. :)

    @BD: I tried googling on your problem of NOD32 and I think there is a similar issue like yours discussed here
  6. zanderzone

    zanderzone Well-Known Member

    @bluediamond ---> boot your computer in safe mod and scan it with Combofix. The program and usage guide could be found here : A guide and tutorial on using ComboFix

    After scanning is complete, install some good anti-virus like Avast in your system and protect it from being getting infected again.

    PS : Stop going to those pr0n sites :p
  7. Emil

    Emil Well-Known Member

    Guys, Scorpy's Q is two years old. He only had this one post and is lost forever somewhere in cyberspace.
  8. medpal

    medpal Resident Medic

    Bluediamond :

    most likely yours is a case of an infection with trojan or worm or virus.

    try to scan you system in safemode with Adaware free and Spybot s and d.

    then again scan your system with nod32 in safemode.

    then try combofix.

    if still problem persists then revert here.
  9. it_waaznt_me

    it_waaznt_me Well-Known Member

    Archana try :
    Start > Run > Cmd {Press Enter}
    sfc /scannow {Press Enter}

    This will check all system files and restore if they are missing. You'll need your operating system cd for files to be restored.
  10. saROMan

    saROMan New Member

    As a System Admin i get the above error from time to time in my company... here are some Tried and Tested methods

    First Try this free tool called Remove Restrictions Tool (RRT) which is able to re-enables all what the virus had previously disabled, and gives you back the control over your own computer.


    Get it from here

    Remove Restrictions Tool is able to re-enable:
    - Registry Tools (regedit)
    - Ctrl+Alt+Del
    - Folder Options
    - Show Hidden Files

    Small and easy to use. Make sure you boot in to Safe Mode to use Remove Restrictions Tool (RRT). Just click on the buttons and it’ll do it’s job.

    Try the following links

    In Case you get the same error with Task Manager try following
    Method 1

    Click Start, Run and type this command exactly as given below: (better - Copy and paste)
    Method 2

    Download and run this REG fix and double-click it.

    Method 3

    • Click Start, Run and type Regedit.exe
    • Navigate to the following branch:
    HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies\ System
    • In the right-pane, delete the value named DisableTaskMgr
    • Close Regedit.exe
    Method 4:
    Using Group Policy Editor - for Windows XP Professional
    • Click Start, Run, type gpedit.msc and click OK.
    • Navigate to this branch:
    User Configuration / Administrative Templates / System / Ctrl+Alt+Delete Options / Remove Task Manager
    • Double-click the Remove Task Manager option.
    • Set the policy to Not Configured.
    Hope it helps!!
  11. Pratik.Sampat

    Pratik.Sampat Well-Known Member

    Dont confuse him guys..

    Dude download Combofix.Run it and will delete all the infections.


  12. medpal

    medpal Resident Medic

    the last inquirer on this thread is not a he but she. :lol:

    nice information saroman there.
  13. bluediamond

    bluediamond Well-Known Member

    after reading medpal's first reply, i had installed spybot and scanned the system. the threats were "win32.delf.uv and hupigon13". then on searching for this on google, found that even though you fix them through spybot it reappears on restart.

    after sometime i understood, that nod32 and other antivirus i installed were not starting up. and this was the symptoms of the above trojans. even Hijack this was not executing.

    Finally installed MBAM and after updating with latest updates, used it to clean the above threats. and rebooted immediately. I guess that solved the problem.

    I had not seen the Spybot "run once at startup" option. So am not sure, it should ve solved the problem. Also installed combofix, but did not had to run it, as spybot and mbam did not show any errors...
  14. pwasim786

    pwasim786 New Member

    Press winkey + R
    Type gpedit.msc

    1. Go to the Group Policy Editor
    2. In That go to the User Configuration >> Administrative Templates >> System >> Prevent Access to Registry Editing Tools
    3. Then Click on the Disabled.
    4. Registry Editor will be Enabled and its cant Give the message "Registry Editing has been disabled by your Administrator".
    5. Now you Disable Prevent Access to Registry Editing tools To your computers user.

    Or Simply Download the Application Called REGISTRY EDITOR HANDLER From Softlink Planet: Registry Editor Handler

Share This Page